Fast, Reliable & Affordable Web Services
Highlights
  • email marketing ...
  • content management ...
  • fastest VPS hosting ...
  • new SEO techniques ...
  • Online business drivers ...

magento and php 5.3

I’m running magento on Centos 5. And, as the Centos mainstream repositories do not support the required PHP version, I am using the very good remi repository.

Just recently remi started supporting PHP 5.3 and magnto is still on PHP 5.2 and does not work well with 5.3.

The main issue is that the split() function is no longer used and needs replacing by explode().

I was able to find all file that contained the split function with :

% grep -Rl “split(” *

and

% grep -Rl “(split(” *

and then open them and replace every call to split with explode.

I don’t why magento don’t provide a centos repository – that would help to avoid a lot of issues and would be a more holistic approach to what they are doing.

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.